Geomajas Runtime Configuration Plugin
  1. Geomajas Runtime Configuration Plugin
  2. RTC-2

setFormula on FeatureStyleInfo doesn`t work correctly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0-M1
    • Environment:

      Geomajas stable release 1.12.8,
      Admin-plugin latest version: 10757 revision from the 21st of June

    • CLA:
      I have read and agree with the Geomajas CLA for the attachments

      Description

      The nabble topic: http://geomajas-developers-list.117808.n3.nabble.com/FeatureStyleInfo-styleId-is-null-td4025405.html

      While trying to colorize shapefile with points or polygons, we found that FeatureStyleInfo.setFormula(...) method doesn`t work correctly.
      If we comment it - the layer is shown on the map(but not colorized, of course).
      It seems that admin plugin works correctly, the errors are in spring while creating the bean.
      The code(and formula also) works ok if we configure it via xml.

      The full code at pastie (the same is in attachment)
      The stacktrace at pastie (the same is in attachment)

      1. AddMultiPolygonLayerAction.java
        9 kB
        Dmitry Dementiev
      2. SaveOrUpdateBeanParameterCommandTest.java
        8 kB
        Dmitry Dementiev
      3. stacktrace.txt
        27 kB
        Dmitry Dementiev

        Issue Links

          Activity

          Dmitry Dementiev added a comment -

          Could you please approximately estimate when you start fixing it? Or it will be even better if you give us some hints on what classes we can debug to handle this situation. The issue is really highly critical for our project. Thank you.

          Joachim Van der Auwera added a comment -

          I am not working on this myself, so I cannot say for sure, but you have to remember that this is an open source project (and more, this plug-in is still unreleased/experimental). If you want this to be fixed quickly and/or it is critical for you, then I would either recommend that you dive into the code to get this fixed, or you contact frank@geosparc.com to have someone fix this for you.

          Dmitry Dementiev added a comment -

          thank you, Joachim, i`ll ask frank to give me the right direction.

          Frank Maes added a comment -

          Start with looking into the RuleInfo class, setFilter method
          Good luck!

          Dmitry Dementiev added a comment -

          Forgot to say that we debugged the code. It seems that on the geomajas side all the beans are prepared properly. But spring can`t create the beans and throws org.springframework.beans.factory.BeanCreationException (the same as in the attached stacktrace). Any thoughts?

          Dmitry Dementiev added a comment -

          Test for the issue. Multipolygons.zip contains shape files that we want to colorize.

          Dmitry Dementiev added a comment -

          Do you have any news about the issue? We attached the test and shp file. Any road map for the bug? Because right now we will be going to openlayers if the bug can`t be fixed in a week or two. Thanks.

          Jan De Moerloose added a comment -

          I will have a look at it right now and see if we can add this to the upcoming release.

          Jan De Moerloose added a comment -

          Fixed, but introduces a dependency on latest backend: 1.12.0-SNAPSHOT
          Thanks to Dmitry for contributing the test.


            People

            • Assignee:
              Jan De Moerloose
              Reporter:
              Dmitry Dementiev
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development